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1. Introduction 

What you will learn from this eBook 

The “WordPress Quick Start Guide:  Your first site in 3 hours” is an eBook and 

companion video training course designed to teach you how to get your first WordPress 

website up and running in three hours, without any prior knowledge.  It will save you 

dozens of hours in research and avoid having to go back and redo anything later, as your 

site grows and becomes more refined (which it will). 

Topics covered in this eBook include 

 WordPress hosting options 

 Basic concepts: site elements and layout 

 Theme selection: your best choices  

 Configuring WordPress for a business website 

 Understanding Posts, Pages and Links  

 Using sidebars and widgets  

 Creating content: the WP built-in Visual editor  

 Installing plugins, and a recommended plugin set  

 Using the free Atahualpa theme framework 

 Creating rich content with Windows Live Writer   

 Graphics editing software (how to make an attractive header for your site) 

How to find out more 

WordPress Academy offers a full course in WordPress website design and internet 

marketing designed specifically for busy professionals and self-employed people without 

a technical background.  Hundreds of people have already taken our high-impact, super-

affordable courses and had their businesses and lives transformed.  For more information 

on this and for much more free content, see http://wpacademy.tv  

  

http://wpacademy.tv/
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2. What is WordPress? (Start here) 

 WordPress is a Content Management System (CMS): it allows you to create 

and maintain a website through an administrative interface, including an 

automatically-generated navigation structure (page menu bar etc), without 

needing to know HTML or learn any other tool. It is simple enough for a beginner 

to learn in a few hours, without sacrificing any power or flexibility.  You can do 

virtually anything with WordPress. 

 WordPress is an Open Source Software: created by thousands of programmers 

all over the world and put into the public domain, so you do not have to pay to use 

it. 

 WordPress is a web-based application, written in PHP and MySQL, and 

optimized for Linux servers.  Meaning: PHP is a programming language for web 

applications, MySQL is a relational database (such as Microsoft Access), and 

Linux is an operating system for web servers – all of these are also open-source. 

 WordPress is, by far, the most popular CMS: over 60 million sites worldwide 

as of late 2011. 

 WordPress is an excellent platform for creating a small business or 

professional website.  Even though it was originally designed as a blogging 

platform, it works very well for creating ordinary (static) websites as well.  It‟s 

also great for membership sites (sites where you sell your content for a fee). 

 WordPress comes with thousands of free themes (templates or styles) and 

plugins (add-on applications).  Changing your theme or adding a plugin is 

extremely easy.   

 Many WordPress users and developers consider it the “shangri-la” of 

website development – the elusive goal of simple and powerful website 

development for non-technical people is now here. Previous platforms were either 

too difficult to learn (Joomla and Drupal CMS‟s), proprietary and too limited 

(Godaddy‟s “Website tonight”), or expensive.   

3. WordPress Hosting options 

Understanding “self-hosted WordPress” sites vs. 
WordPress.com 

You can create a free WordPress blog at WordPress.com, and then assign it to your own 

domain name for about $20 per year. The content will be hosted on the WordPress 

servers, and as such you need not worry about hosting. 

WordPress.com is not recommended for hosting professional websites, because it has 

a limited number of available themes and plugins.  In particular, commercial themes are 

not supported, nor even the free Atahualpa theme framework that we recommend. You 

will further be limited in terms of your ability to really customize the site as 

Wordpress.com does not give you access to your PHP code. 

It‟s much better to host your WordPress site yourself using the so-called “self-hosted 
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WordPress”.  

Understanding domain and hosting 

Properly hosting a new, self-hosted WordPress site is challenging for beginners, however 

if you read carefully below and follow the instructions you should be good.   

To host a website (any website including self-hosted WordPress), you need a Domain 

Name Registrar company (e.g. GoDaddy) and a Hosting Company (e.g. BlueHost).  

Occasionally, the same company handles both, but we recommend that you keep them 

separate, e.g. register your domains through your domain registrar, not through your 

hosting company. Hosting companies are sometimes known to include one free domain 

name in the hosting plan but then charge a premium fee for additional domains.  And 

domain registrars (such as Godaddy) often do not provide great hosting service.   

Exception to this rule: if you are just starting out your first site it‟s ok to register your first 

domain name when you first purchase hosting, for instance from Bluehost (see below); 

however you should register additional domains through your registrar and then point 

them (assign them) to your hosting account as described below.   

Any good hosting company will allow unlimited domain hosting.  This means you can 

have multiple domains with separate websites under one monthly hosting fee.  You really 

should never need more than one hosting company.   

Be aware as well that transferring domains from one domain registrar to another, and 

websites from one host to another, can be an administrative nightmare. Save yourself 

from this by having only one hosting company and only one domain registrar from the 

get-go (see below for some good choices).  Failure to understand this has been the cause 

of endless headaches to my students. 

Choosing a domain registrar 

The companies below are all excellent domain registrars and more-or-less equivalent in 

terms of pricing 

 Godaddy.com 

 Domain.com 

 NameCheap.com 

Resist the temptation to buy hosting from your domain registrar, and most certainly do 

not purchase any additional domain services such as private registration, traffic, etc. They 

are very rarely useful or necessary. 

Choosing a webhost   

Your hosting company holds (or “stores”) the files on your website to anyone who asks 

for them anywhere in the world. Hosting companies run banks of web servers, which are 

essentially big computers that are always turned on, connected to the internet, and 

monitored 24 hours in case of failure. 

The leading hosting companies are listed below.  They are all quite similar in terms of 

pricing, service level and reliability. Prices range from $6 to $12 per month, depending 

http://godaddy.com/
http://wpacademy.tv/bluehost
http://wpacademy.tv/bluehost
http://godaddy.com/
http://domain.com/
http://namecheap.com/
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on the contract duration, options, and whether the domain name is included or not.   

BlueHost, Hostgator and WordPress Academy are all cPanel style hosts, which are 

recommended for user-friendliness and stability. 

 BlueHost. Perhaps the best all-around value, particularly for newbie‟s.  It does require 

a year prepay, but includes one domain name, and uses the easier cPanel interface. 

 Hostgator.  Also a great company.  Unique among companies listed here, it offers so-

called “reseller hosting” plans, where you can set your clients up with their own 

hosting control panels and charge them for it. This can be especially interesting for 

website designers.  

 WordPress Academy Hosting.  If you are primarily planning on hosting WordPress 

sites, you should consider a specialized WordPress hosting service.  Most hosting 

companies treat WordPress as an “application” which means that you are responsible 

for maintaining and debugging it – e.g. if your site gets hacked or starts getting PHP 

errors, you are on your own (good luck ). WordPress Academy hosting is very 

price-competitive with traditional hosting providers and you will have greater peace 

of mind knowing that your WordPress sites are fully supported. 

 GoDaddy.  World‟s leading domain name registrar and hosting provider. Godaddy is 

not recommended for WordPress hosting as their control panel interface is difficult to 

navigate.  If you must use them, make sure you buy the Deluxe or Unlimited plan so 

you can host multiple sites.   

 

Additional Notes on web hosting 

 Remember that even if your hosting company allows you to host unlimited domains, 

you still need to pay the yearly registration fee for each domain you are hosting, 

which is currently about $10/yr. 

 It‟s preferable to install WordPress on a Linux hosting server. This is usually not an 

issue since all low-cost hosting accounts are Linux-based. If you already have 

Windows hosting, WordPress will run fine on it, though. 

 Never purchase hosting based on price alone. There are other elements in the 

equation, like server speed and reliability. If you have email accounts attached to your 

domain name (you@yourdomain.com) the email is managed by your web server 

(hosting company), and if the server goes down so does your email (sometimes for 

days) 

 If you are just learning, and/or programming websites in PHP, you could use local 

server hosting  instead – it only takes a few minutes to install on your computer (and 

is a fun exercise to do anyway).   

 Moving WordPress sites from one host to another is tricky, so its best if you build 

your sites on the host and domain that is going to ultimately hold it.  If you must 

move your WordPress site after it‟s complete, see this article. 

 If you are building a new version of an existing website, intending to replace the 

http://wpacademy.tv/bluehost
http://hostgator.com/
http://wpacademy.tv/host/
http://godaddy.com/
http://wpacademy.tv/how-to-install-wordpress-php-mysql-to-a-local-development-server-environment-on-windows-or-mac-in-3-minutes.htm/
http://wpacademy.tv/how-to-install-wordpress-php-mysql-to-a-local-development-server-environment-on-windows-or-mac-in-3-minutes.htm/
http://codex.wordpress.org/Moving_WordPress
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original, build it in a subdirectory i.e. http://mycompany.com/new, and then move it 

to the root directory when you are done.  

 

How to assign a domain name to a hosting account 
(understanding “name servers”) 

Pairing webhost and registrar is also called “hosting your domain”. 

1. If you don‟t yet have a hosting account, sign up for one (see above).   

2. If you are hosting the primary domain of your site, your domain is automatically 

hosted when you open your hosting account, so skip directly to step 6. 

3. If you want to create an additional website in your hosting plan (assuming that 

your hosting plan allows it), do the following: 

- If you have a cPanel hosting account (such as BlueHost or Hostgator), open 

your hosting control panel and choose the “add-on domain” function, which 

assigns the domain name to a sub-directory of your site.  For more information 

see this article.  

- If you are using GoDaddy, open the domain in your control panel and then 

select the “Hosting” option for that domain, and create an additional hosted 

domain.  

4. Go to your domain registrar control panel, and from there set the Name 

Servers of your domain as instructed by your hosting company (i.e. if you are 

using BlueHost you would set your Primary and Secondary name servers to 

NS1.BLUEHOST.COM and NS2.BLUEHOST.COM respectively).  GoDaddy 

will do this for you automatically if you follow the previous step. 

5. Your website will typically be visible on the web (“resolved to your domain 

name”) within 5-10 minutes – overnight maximum (this delay is called “domain 

propagation time”). If you have not yet installed WordPress or put any files on 

your site you will see either an “empty directory listing” or else the default 

landing page for your hosting company.  

6. Once your site is hosted, use the automated WordPress installer on your hosting 

control panel to install a fresh WordPress site to your domain. If all goes well, 

you will now see the default WordPress installation at http://yourdomain.com  

Tip: it is generally easier to assign your name servers when you first purchase your 

domain name rather than after you have bought it. This also eliminates the domain 

propagation delay, allowing your site to come online immediately.  If registering your 

domains at GoDaddy, look for a little box that says “Set name servers” during the 

purchase cycle. 

Installing WordPress on your domain 

Once your domain is “hosted”, you can install WordPress on it. Almost all hosts have a 

2-click WordPress installer program. Google “Installing WordPress on [your hosting 

http://wpacademy.tv/forum/reference/how-to-host-another-website-domain-via-the-add-on-domain-function/
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company]” for instructions, or else review the Installation tutorials on WordPress.TV. If 

you have a cPanel-style hosts review this article.   

A WordPress installation consists both of PHP files and a MySQL database. Backing it 

up fully will require both backing up the PHP files and the database. See below for how 

to backup your site‟s database (use plugin WP-DB-Backup). Most of your site‟s 

configuration is kept in your database, so failure to backup your PHP files is generally 

not a big issue in the case of failure (but do it anyway for precaution). You can also 

backup your entire site through your hosting control panel. 

Creating email accounts with your domain name 

Once your domain is hosted you may want to create email addresses attached to your 

domain e.g. you@yourdomain.com. This is done within the hosting control panel.  

 There are two ways you can create an email address attached to your domain name: 

 A Forwarding email address just forwards to another email (i.e. your Gmail) 

 A POP3 email address stores the email on the server and downloads to your 

computer through your email client program (i.e. Microsoft Outlook etc.) 

Both have advantages and disadvantages over the other. Generally, it is faster to read and 

process email in an email program (email client) rather than a web-based client (e.g. 

Gmail). The trade-off is that web-based email allows access to your email from 

anywhere, and may have better spam filtering.   

We recommend that you use Gmail as the email server for your domain through the free 

Google Apps service, which provides the best of both worlds. This is a bit technical to 

setup, however.  It is explained in this video.  If you can‟t do this, it‟s perhaps best to 

forward your mail you@yourdomain.com to a regular Gmail account, which is easy to 

do.   

Note: all major web hosting companies provide Webmail interfaces to their POP3 email 

accounts, so you can still read your mail via POP3 at home and access it from the road.  

However, once your POP3 email is downloaded to your computer (once it is read), it is 

no longer accessible through webmail. 

  

http://wordpress.tv/category/how-to/installation-how-to/
http://wpacademy.tv/forum/faqs-reference-library/how-to-install-wordpress-on-your-primary-domain-and-add-on-domain-or-a-sub-domain/#p53
http://wpacademy.tv/googleapps.htm/
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4. WordPress basic concepts & layouts 

Once you have successfully hosted your domain and installed WordPress on it, you are 

ready to begin creating your content and styling your site.   

Here is what WordPress looks like after installation of one our favorite free themes, 

Atahualpa (see below about themes and installing themes).  You need to understand this 

basic layout (which is the same or similar for all WordPress sites) in order to design your 

site‟s layout and navigation.   

Every theme looks different but they share all or some of the elements below. 

 

Notes: 

 When you first install WordPress, the installer automatically creates a page called 

“About”, a Post called “Hello World”, and a set of links in the category “Blogroll”.  

The first thing you will typically do is to delete these and create your own content. 

See below for the difference between Pages, Posts and Links. 

 Your center-page will display content from your most recent posts (if you have 

configured your site as a blog) or it will show a static page called “Home”, if you 

have configured your site as a business website (static site) – see below.   

 Until you put content (widgets) into your sidebars, WordPress will populate them 

with default widgets.  In the example above, the left sidebar is automatically filled 

with a “Categories” and an “Archives” widget, and the right sidebar has a “Recent 

Posts” and a “Links” widget.  To replace these with your own content, see below.   
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 The page navigation is usually located on a horizontal bar (with or without drop-

downs to sub-pages), above or below the header image (or website banner). If you 

prefer, you can put your top-level navigation on your sidebar by placing a “pages 

widget” there (see below for what a “pages widget” is)  

 The page navigation bar normally contains only your static pages (WordPress 

“Pages”) and is auto-generated, but you can link to pretty much anything you want, 

like blog categories or external links. 

 In the Atahualpa theme, the Title and Tagline can overlay the banner image. Or, you 

may remove the Title and Tagline altogether and place them in your banner as image 

text (see below “Making a banner using Paint.net”).  

 You must think about your sidebar configuration. Depending on your theme, you can 

have up to 4 sidebars. Some themes and theme frameworks will also allow you to 

selectively set visibility of sidebars according to page type (Page or Post) or by Page 

ID (i.e. turn off side-bars for the home page). 

5. Theme Selection 

Finding a good theme 

This is your most important initial decision after you have first installed WordPress. Here 

is why: 

 Your site‟s appearance and initial impression is determined largely by two things: 

your theme, and the graphic density of your site (number and quality of graphics, 

such as your header). A good theme will make the difference between a 

professional-looking site and one that isn‟t.  So start with a good theme and then 

add professional (or semi-professional) graphics – see below. 

 You should choose your theme fairly soon after you begin your site, since it has 

an impact on how you create your content (i.e. two or three-column layouts, 

screen width, etc).  In WordPress, content is mostly separate from presentation, so 

you can always change your theme later. However, if you do this, you will lose 

most of the work that you have put into styling and customizing your theme (you 

will need to start fresh making stylistic adjustment to the new theme). 

 Themes are customizable to differing degrees. Modifying the PHP theme files 

directly is possible in all themes, but you want to avoid this if you can (unless you 

want to learn PHP programming).  You are better off choosing a theme that 

already has the functionality and look that you want.  You are also typically better 

off choosing a Theme framework over a regular theme. A theme framework 

allows you to customize many directly through the theme options page. A good 

theme framework will allow you to select the number of sidebars, width of 

sidebars, all your fonts and colors, and much more through the WordPress 

dashboard.  This may save you hours (or days) of wandering through stylesheets 

(CSS files) and PHP.   
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Free theme or commercial theme? 

As a professional WordPress educator, I used to work a lot with free themes and 

recommend them to my clients (particularly the very powerful free Atahualpa theme 

framework). However, recently I have been working almost exclusively with commercial 

themes for many reasons: 

 Very few free themes are actually Theme Frameworks.  What this means is that if 

you want to add another sidebar or even change basic things such as the width of 

the site, you may need to hire a programmer. On the other hand, most 

recommended commercial themes below are already fully-developed theme 

frameworks. 

 It‟s difficult (or impossible) to find a free theme that both looks good out-of-the-

box, and provides a high degree of customizability (ie a theme that operates more 

as a theme framework than a theme).  Many commercial theme families, however,   

do both really well. 

 Most commercial themes cost in the range of $60-$80.  It‟s usually not worth 

saving $80 in order to spend an extra dozen hours styling your site (and then 

possibly failing to get the look-and-feel you want anyway and having to start 

again). 

 All commercial themes provide some degree of support, usually through a forum. 

Free themes, on the other hand, may not be supported at all (Exception: free 

Atahualpa theme support is excellent) 

Best (recommended) commercial themes 

The following themes / theme frameworks are all recommended: 

 StudioPress: one of the best choices overall. Very rich theme family with a lot of 

customization power.   

 Woothemes: another excellent, very diverse and powerful theme family 

 Thesis: A very solid, highly customizable theme, and one of the most popular 

themes on the web.  Thesis themed sites generally look alike unless you do some 

serious customization, however the flexibility and performance makes up for that 

(and they are designed to be easily customized in a number of ways) 

If you can‟t find anything you like from the above, try the following: 

 Theme Forest: a large commercial theme collection.  Many are quite attractive but 

note that you will be getting a theme, not a theme framework. 

 iThemes (Builder or Flexx especially) 

Last, consider: 

 Artisteer ($50).  This is Windows software that allows you to design the layout 

locally and provides a lot of options. When you are done, export the theme files 

and upload to your site with FTP. It creates visually rich sites, although a bit on 

the simple side. Also works for Joomla and Drupal content management systems. 

http://wpacademy.tv/studiopress
http://wpacademy.tv/woothemes
http://wpacademy.tv/thesis
http://themeforest.com/
http://ithemes.com/
http://wordpressacademy.biz/artisteer


http://WPApacademy.tv  Page 12 of 31 

 

Best free themes 

If you are just starting out you can check some of the attractive free themes available for 

download from the WordPress.org theme directory. All of the themes below can be 

installed to your site directly in a few clicks from WordPress.org (see how below). 

1. Start with WordPress‟ most popular (free) themes – you may find a bull‟s eye 

theme there, and if not, you might get some ideas. Remember that there are 

disadvantages to using a regular theme vs. a theme framework, even if that theme 

is great from a visual point of view. 

2. One of the best free theme frameworks is Weaver.  It looks pretty good and has a 

lot of customizability. 

3. Consider Atahualpa as probably the most powerful free theme framework. It 

rivals commercial products in its sophistication.  However, it looks a bit dull out-

of-the-box (be prepared to tweak it) 

4. If you are looking for a theme for a specific business type, try searching the 

WordPress.org free themes directory site or else Googling it directly (i.e. 

“WordPress theme for therapist”). 

5. Other suggestions: White House, Hybrid, Thematic, Revolution and Lysa. These 

are all clean, uncluttered themes, suitable for any type of professional site. 

Installing and activating your theme 

If you are using a free theme, install and activate it directly through your dashboard: 

Appearance > Add New Theme, search for it by name, then install and activate it. 

If you purchase a commercial theme, you will need to upload it to your web site and 

activate it.  The easiest way to do this is via the Theme > Add New Theme command (in 

your WordPress dashboard). Select the "Upload" tab, find and upload the theme zip file 

provided by your theme vendor.   

The second way is to unzip the theme files and upload them via FTP.  You will need FTP 

client software for this (e.g. FileZilla), and you will need to know your hosting account 

username and password.  See this article for additional instructions. 

How to customize (style) a theme 

The first thing you will usually do is add a company banner (site header) and logo. See 

below for making a header using the free image editing software Paint.net (available only 

on Windows).   

You will usually need to upload your banner image to your website using FTP, and place 

it inside the correct directory of your server. Some themes (such as the recommended 

Weaver theme) have a dashboard interface for adding a header (you won‟t need FTP) 

http://wordpress.org/extend/themes/browse/popular/
http://wordpress.org/extend/themes/weaver
http://wordpress.org/extend/themes/atahualpa
http://wordpress.org/extend/themes
http://wordpress.org/extend/themes/whitehouse
http://wordpress.org/extend/themes/hybrid
http://wordpress.org/extend/themes/thematic
http://wordpress.org/extend/themes/revolution-code-blue
http://wordpress.org/extend/themes/lysa
http://filezilla-project.org/
http://codex.wordpress.org/Using_Themes
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Once your theme is installed, check out your customizable theme options (in WordPress 

Admin > Appearance > Theme Options).  If you are using a theme framework, you will 

be able to set the width of your site, the presence of sidebars, and many other options. 

The best themes and theme frameworks also give you control of the styling of every 

element of your site, such as background color, font, margins, etc. You need to know a 

little CSS to do this, but this is quite simple and if in doubt you can Google “CSS 

background color” for the precise syntax, or to go to W3Schools CSS tutorial. 

If your theme options page doesn‟t expose all the CSS styles, you can still modify the 

CSS file directly. This is a bit technical, and not recommended for regular users.  If you 

want to try it, however, you can access your site‟s CSS file in Appearance > Edit and 

then edit the CSS file from there. 

If you are modifying your site‟s CSS, you might want to take a look at Firebug, a Firefox 

add-on that lets you examine each element of another site you like, view the underlying 

CSS code, and modify the CSS code on the fly and see the results.  You can use it, 

essentially, to copy the styling of any site on the internet (and it‟s legal!). 

Note: CSS styling commands need the hex color code, something like #AA0944 – this is 

hexadecimal notation, two hex digits each for the color values: Red, Green, and Blue (00 

to FF). You can find / detect color settings on another website using the Firefox 

Colorzilla add-on. 

Special instructions for Atahualpa theme users 

We have made a 30-minute video on YouTube to teach you specifically how to style the 

very powerful free Atahualpa theme framework. Check it out. 

http://www.w3schools.com/css/default.asp
http://getfirebug.com/
https://addons.mozilla.org/en-US/firefox/addon/271
http://www.youtube.com/user/everymanmarketing
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Understanding Posts, Pages and Links 

You need to understand the basic WordPress data elements. 

 Posts are time-sensitive articles, and are normally listed on your “Blog” page in 

reverse chronological order.  You may choose not to have a “Blog” page at all (e.g. 

your site could have only static pages or “Pages”), OR you may choose to configure 

your WordPress site as a blog and to have your home page display your blog posts 

(this is the default configuration).  Posts allow comments, although you can close or 

disable comments on individual posts. 

Posts have categories.  You set up your post categories in the Posts > Categories 

menu.  If you create a post but don‟t assign a category, it automatically gets assigned 

to the “Uncategorized” category (which you can rename to something else).  

Categories can show up on your sidebar with the “Post categories” widget. 

 Pages are so-called static pages – they display content that isn‟t time-sensitive, such 

as your Home page, About Us, Services page, and so on.   

Pages do not normally allow comments, nor are they part of your RSS feed (content 

distribution).  

Pages do not have categories, but can be created in a hierarchical structure. 

Depending on your theme, this could allow you to create drop-down menus in your 

navigation bar. 

 

“Resources”, “About us” are top-level pages (no parent).  “WordPress Themes” etc 

are child pages of the “Resources” page. 

 Links are just that – URL‟s to other pages on your site, or to external web pages. 

Links have categories too, albeit different from the post categories. The beauty of 

link categories is that you can use it to automatically populate your sidebars with 

groups of links, just by placing a single widget in your sidebar – see below. 

Additional Notes: 

 Posts, Pages and Links are each created from their own menus in your dashboard. 

 There are “widgets” (see below) that allow you to automatically put your list of 

Pages, Recent Posts, Posts by Category, Posts Archive, Post Comments, and other 

content directly into your sidebar(s). 
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6. Basic WordPress configuration 

Many of WordPress‟ default settings are good, but you will want to change the following.  

If you are setting up a static website (meaning a site that display a home page, such as 

virtually all business sites), this step is required.   

Do this from your site dashboard, at http://yoursitename.com/wp-admin.   

 Settings > General: Your blog name and tagline (tagline may appear on your 

header) 

 Settings > Writing: Check the box “Enable the WordPress, Movable Type, 

MetaWeblog and Blogger XML-RPC publishing protocols” in order for Windows 

Live Writer to work (see below)  

 Settings > Reading: This is where you decide if you are making a blog (posts on 

home page) or a static website (static home page). WordPress is configured as a blog 

by default. A company website will often have a static landing page, and a blog 

subsection of the site. Here‟s how you configure it. 

Create two pages called “Home” (this is your home page), and “Blog” (this is a 

“place-holder” page – WordPress will fill it with your latest posts).  Then select 

Front Page displays > A static home page and put “Home” and “Blog” in the drop-

down menu. 

 
Now go back to your site, refresh, and select your “Blog” page in your top page 

navigation bar – you will see it filled it with your most recent posts. 

 Settings > Privacy.  Select “I would like my blog to be visible to everyone” (this 

modifies your robots.txt file – informs search-engines of your intentions). 

 Settings > Permalinks.  Makes your URL‟s (links to your articles) friendlier by 

putting the post or page title in the URL.  Generally, you will select Month and 

Name. 
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7. Using the WordPress built-in Visual Editor 

To create a new Page or Post, use Page > Add New to Post > Add New.  This will open 

up the WordPress Visual Editor. Make special note of the following: 

 

The editor is pretty straightforward and easy to use. For a more extensive introduction, 

check out the video tutorial How to format content using the WordPress WYSIWYG 

editor. 

http://knowledgeconstructs.com/wordpress-video-tutorials/how-to-format-content-using-the-wordpress-visual-editor/
http://knowledgeconstructs.com/wordpress-video-tutorials/how-to-format-content-using-the-wordpress-visual-editor/
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Notes:  

 Add an image to your Media Library (and post it automatically in your article) with 

the “Upload / Insert Image” icon on the top left: .  

 Alternatively, use Windows Live Writer to create your posts, as described below. 

As an alternative to the above, I recommend that you upgrade to the Tiny MCE 

Advanced editor 

  

http://wordpressacademy.biz/2010/02/using-the-wordpress-advanced-visual-editor-tinymce-advanced-to-apply-css-styles-edit-tables-search-and-replace-spell-check-and-more/
http://wordpressacademy.biz/2010/02/using-the-wordpress-advanced-visual-editor-tinymce-advanced-to-apply-css-styles-edit-tables-search-and-replace-spell-check-and-more/
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8. Sidebars and Widgets 

Widgets offer new and exciting ways to remix and display your site‟s content, often in 

one of the sidebars. For more information, you may want to begin with the Widget 

Overview video on WordPress.TV 

To configure the widgets for your site, 

1. Go to Appearance > Widgets in your WP Dashboard. 

2. On the left you will see all your available widgets.  Some of these may be 

standard widgets that are installed by default in WordPress; others may be created 

by plugins (see below).  For example the “My Link Order” widget is 

automatically created when you install that plugin. 

3. To insert a widget into a sidebar, first expand the sidebar by pulling it down 

(arrow on the right).  Then “Drag and Drop” your widgets from the center-page 

onto your sidebar and click “Save”. 

In the example below, we are putting a “Pages” widget into our left sidebar, right 

below the “Category Posts” widget. This will automatically populate your sidebar 

with the list of static pages on your site. 

 

 

  

http://wordpress.tv/2009/07/24/wpcom-widgets/
http://wordpress.tv/2009/07/24/wpcom-widgets/
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To illustrate this idea further, it‟s best to use an example – below is an example page 

from the WordPress Academy “How-To” page, a blog type page. 

Read this diagram carefully, and the next diagram as well, as it explains how to setup 

your sidebars however you want.  
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Here is what the right side of Appearance > Widgets looks like in order to generate this 

layout:   

 

Note that this layout (as most WordPress layouts) makes extensive use of the Text 

widget. This widget allows you to put arbitrary HTML text and images onto your 

sidebars (or even, in the case of the Advanced Text Widget, PHP code!) 

Additional help on Widgets and navigating the WordPress User 
Interface 

For additional tutorials see the WordPress.TV How-To section. If there is anything that 

you find particularly helpful there, just drop me an email and I will update this document 

with the link.   

http://wordpress.tv/category/how-to/
mailto:marc@everymanmarketing.com
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9. Installing a recommended Plugin set 

A WordPress “Plugin” is a piece of software that is designed to perform a specific 

function and integrates seamlessly with your blog.  Most plugins are free and can be 

installed directly through your dashboard.   

Until you specifically “activate” them, plugins do not work on your site (they appear in 

your plugins menu as inactive, and have no effect). So, if a plugin starts giving you 

problems, just deactivate it.  An inactive plugin can also be deleted, which physically 

removes the plugin files from your site. 

The following is the recommended minimum plugin set for all WordPress self-hosted 

sites.  Install each of them from Plugins > Add New. Enter the name in the search box, 

followed by Install and Activate: 

 My Link Order lets you order links and link categories by drag-and-drop. 

 Subscribe to Comments allows users who comment on your articles to subscribe to 

follow-up comments, so they get notified when someone replies to them. 

 SI Captcha requires people who comment to fill-in a “captcha” code (4 digit 

computer-generated number) to make sure they are not spambots.  This is advised to 

protect you from spam comments.  Note: you can also install Akismet (spam filter) 

but Akismet sometimes sends legitimate comments to your spam filter. 

 Redirection allows you to redirect one page to another.  Useful when you change the 

URL for an article, and for putting easy-to-remember affiliate links to your site (i.e. 

http://everymanmarketing.com/bluehost redirects to a Bluehost affiliate link – only a 

programmer can see the actual redirected link) 

 All-in-One SEO gives you fine-grained of all your meta-tags and site description. 

Some themes (particularly Thesis) have their own SEO and you won‟t need All-In-

One. 

 Google Analyticator is easy interface to free Google Analytics service.   

 XML Sitemap automatically generates an XML sitemap 

 WP-DB-BACKUP allows you to backup your site.  

 

Notes 

Some plugins automatically create new widgets. For example the “My Link Order” 

plugin (above) creates a widget that lets you put ordered links and links categories to 

your sidebar. 

Don‟t install plugins from untrustworthy sources, as plugins directly execute PHP code, 

which could even take your site down.  Anything you can see in your dashboard from 

Plugins > Add New comes from WordPress.org and is probably ok, albeit not guaranteed 

to work.   

http://everymanmarketing.com/bluehost
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Also note some very cool plugins (PHP Execution or Advanced Text Widget) that can 

directly execute your own (arbitrary) PHP code inside your pages and sidebars. If you 

know PHP, this will give you programmatic control of your sidebars content.   



http://WPApacademy.tv  Page 23 of 31 

 

10. Creating a header (banner) for your website 

Every website needs a decent header. Here‟s how to create one yourself in a flash. 

I love the free image editing software Paint.Net.  Unfortunately it only works on 

Windows.  If you are on Mac, try the free Gimp, which is also very good but harder to 

use.  Alternatively, you purchase Photoshop elements for about $100 or use the free (and 

excellent) online graphic editor Sumo Paint.  

Although the instructions below apply specifically to Paint.Net, the concepts are 

applicable to any image editing software. 

Here is the final result we are going to produce. 

 

1. Start Paint.Net.  Make sure the Tools window, the Layers window, and the 

Colors window are visible.  If not, enable them from the View menu. 

 

2. Go to your favorite free stock photography site (Google “free stock photography” 

or check Stock.XCHNG), find the image you want for your logo, view it at the 

largest possible resolution, then Right-Click > Copy 

 

http://www.getpaint.net/
http://www.gimp.org/
http://sumopaint.com/
http://www.getpaint.net/
http://www.sxc.hu/
http://wordpressacademy.biz/wp-content/uploads/2010/02/swan2.jpg
http://wordpressacademy.biz/wp-content/uploads/2010/02/image20.png
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3. Edit > Paste in to New Image 

 

4. Click on Rectangle Select on the Tools Window (top left) and use it to select 

the part of the image that you want.  Leave some space at the right to do the 

image fade-out (see below). 

 

5. Do Image > Crop to Selection 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image21.png
http://wordpressacademy.biz/wp-content/uploads/2010/02/image23.png
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6. Decide on the banner height: 150 pixels is a good height. Do Image > Resize and 

enter a Height of 150 and OK. 

 

7. Choose your width depending on the width of your website (normally either 800 

or 1000 pixels).  Then go to Image > Canvas Size and put in a Width of 800. Do 

not check Maintain Aspect Ratio 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image24.png
http://wordpressacademy.biz/wp-content/uploads/2010/02/image25.png
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Notice the right of the image has filled with empty or transparent pixels. If you 

are using a variable-width theme or template and using the image for the 

background image of the header area, you need to make it at least 1800 pixels, 

even though most browsers will only see the first 1000 or 1200 pixels of width. 

8. Now let‟s insert a background color / layer.  Go to Layers > Add New Layer.  The 

Image will remain unchanged but note the Layers window now shows a new 

layer, “Layer 2”. 

 

9. First, for clarity sake, double click on “Layer 1” in the Layers Window and call it 

“Swan”.  Now double-click on “Layer 2” and call it “Background” 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image26.png
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To understand layers, uncheck the box next to “Swan” on the Layers Window.  This 

makes that layer not visible.  Now you only see the empty (transparent pixels) 

“Background” layer 

 

Within our image-editing program, every layer is a separate image. Images show up in a 

top-to-bottom layer order. The only reason we can see the layers „beneath‟ is because 

there are transparent pixels on the upper layer(s).  

The only reason the swan was showing at all is because the topmost “Background” layer 

is filled with empty (transparent) pixels. 

10. Let‟s fill this background with a blue color closest to our original picture. First, 

make the Swan layer visible again and the Background layer invisible. Then 

select the Color Picker on the Tools Window and click on a darker area of the 

swan picture.  

Notice the Primary color on the Colors Window has changed to a dark blue. 

11. Go back to your background layer (click it in the Layers Window), select the 

Paint Bucket Tool  and click anywhere on the image. The entire image goes 

dark blue! 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image29.png
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The reason, of course, is that the “Background” layer is on top of the “Swan” 

layer. 

12. Move the Background layer down below the Swan layer. Click on “Background” 

in the layers window and then the down arrow: 

 

13. Next, go back to the Swan layer and select part of the overlap between the two 

layers. Go to Effects > Blurs > Gaussian blur to create a fade-over effect. 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image33.png
http://wordpressacademy.biz/wp-content/uploads/2010/02/image34.png
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14. Now use the Text tool  to write your banner text. 

 

15. You can insert any other image by following the same procedure: add a new 

layer, crop and resize.  Remember new layers won‟t be visible now unless they 

are on top. 

Hint - You can increase the screen resolution (visible size of your image) in the 

View menu, or else by putting your mouse over the image and Ctrl + move the 

mouse scroll bar. 

16. Now save the .pdn files, with all layers intact, in case you want to work more on it 

later. Then File > Save and save it as jpg to upload it to your website. 

 

. 

http://wordpressacademy.biz/wp-content/uploads/2010/02/image36.png
http://wordpressacademy.biz/wp-content/uploads/2010/02/image37.png
http://wordpressacademy.biz/wp-content/uploads/2010/02/image38.png
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11. Windows Live Writer  

Windows Live Writer is a marvelous tool for creating rich content on your blog offline. It 

is much more powerful than the built-in WordPress visual editor and is particularly useful 

when publishing text with a lot of images or video.  With Live Writer, you create your 

content offline and publish it using WordPress‟ built-in XML-RPC protocol (this must be 

enabled for your blog – see your Settings menu).  

The normal way to publish text and images to WordPress is this: 

1. Capture or save the source image to your hard-drive. 

2. Upload the image in the WordPress visual editor, crop and resize from there. 

This can be a lot of keystrokes and a lot of navigating file directories.  Using Windows 

Live Writer, you can cut both of the above steps short.  What you do is: 

1. Copy the image from any web or disk location (from your web browser, just 

right-click > Copy); or else use a free screen capture utility such as Cropper.  

2. Paste into Live Writer.  You can resize, hyperlink or apply effects (shadow-

borders for example) to the image directly 

3. Publish your post.  Live Writer will connect to your host and publish the image 

automatically to your wpcontent/uploads directory 

You can also use this technique to generate pretty newsletter emails to your customers.   

First, set up any RSS-to-email service such as Feedblitz, Feedburner or Aweber. Then 

just publish a post.  For more information see Using Feedblitz or Feedburner as your 

newsletter system (mailing list management). 

  

http://windowslivewriter.spaces.live.com/
http://www.codeplex.com/cropper
http://wpacademy.tv/using-feedburner-or-feedblitz-for-your-newsletter-mailing-list-management-system-on-wordpress
http://wpacademy.tv/using-feedburner-or-feedblitz-for-your-newsletter-mailing-list-management-system-on-wordpress
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12. Conclusion 

In this guide I have tried to lay out the basic concepts and knowledge you need to design 

an attractive and functional website using WordPress. Hopefully this has been useful to 

you (obviously it has, if you have read this far ) 

Of course there is much more that you can learn and do with WordPress – unlike most 

any other content management system ever produced, WordPress is not only free and 

easy enough for a beginner to use, it also allows infinite degree of customization and 

control.   

If you enjoyed this eBook, I hope that you will consider joining one of our webinars  

that will teach you a great deal more and may allow you to really create a killer site 

that will both attract traffic and make you some money.   

Mazel Tov! This means, if I understand it correctly, “Good luck has occurred”. I think 

the development of WordPress is, in fact, a great good luck for all of us self-employed 

people, small business owners, budding entrepreneurs, non-profits and world-changers. 
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